Rhino 6 and 7 - Version History

 

MAXWELL 5


Maxwell Rhino v5.2.6.1 - 06 Jul 2021

COMPATIBILITY:
  • Built for Maxwell Render 5.2.1.49

 

ADDED:
  • Added custom Maxwell Extension Objects:

    • Maxwell Sea; it has a water material assigned by default, with a subtle blueish tint and attenuation effect.

    • Maxwell Volumetric

  • Added new buttons to the Maxwell Tools toolbar:

    • Add Maxwell Sea

    • Add Maxwell Volumetric

  • New object modifier accessible from the Maxwell Extensions panel: SubdivisionModifier (it won’t show correctly in FIRE, but will do in render).

  • Added “Export as .mxm” option to the right-click context menu of the Maxwell materials to export the materials individually to an MXM file. It also gives the option to turn the material as a referenced after it has been stored.

  • Added a new command "Maxwell_ToggleVisuals" to toggle the display of Maxwell-related visuals aids to locate in the viewport the grass blades and scattered instances.

  • Added a new button to the Maxwell Tools toolbar: "Toggle Visuals"

  • Added a new command "Maxwell_ExportMaterials" to export all the Maxwell Materials as MXM into a selected folder.

  • Added a new button to the Maxwell Materials toolbar: "Export Materials"

  • Added Referenced MXS "Point Cloud" display mode type.

  • Added Maxwell_PathFix command and menu item. It’s a semi-automatic tool to replace missing plugin-related files:

    • Maxwell Textures (file paths)

    • Maxwell Materials (referenced mxm/emitter IES file paths)

    • Referenced MXS (file paths)

    • Light object (IES/projector image paths)

    • Maxwell Environment (IBL paths)

    • Maxwell Render Settings (extra sampling / simulens aperture and obstacle paths)

  • Added a new button in Maxwell Tools toolbar: "Path Fix"

  • Added a new Maxwell for Rhino Properties parameter in the MXM Gallery section: "To sub-folder". In case it is ON it creates a sub-folder for each downloaded MXM material file.

  • Added Load/Save buttons for Maxwell extensions and material assistants to easily handle user-made presets.

  • Added Object parameter: Recalculate normals. It allows overriding the current smoothing of the objects in render time. The numeric field represents the angle of smoothing. If the angle between adjacent polygons is smaller or equal to this angle, the faces will be smoothed.

  • Added Object parameter: Backface material. Now you can assign a different material to the back faces of an object.

  • Added the option to also assign custom alpha channels per material. This means:

    • A new section in the custom alpha panel for the materials

    • A new custom alpha section in the Global Properties of the materials.

  • Added an icon for the Maxwell Extensions Panel.

  • The Substance Designer and Substance Painter assistants now have three new parameters to control the displacement subdivisions, displacement height and the emitter intensity, so you don’t have to convert the material to advanced in order to control those features.

 

IMPROVED:
  • Maxwell Grass uses the pre-defined default Maxwell Grass material in case no material was assigned to it. It features a thin subsurface scattering material with a subtle green gradient mapped from root to tip and should work best with the flat blade type (default).

  • Now the plugin takes into account the transparency of the materials and shows it in the viewport (depending on your display mode settings).

  • The Referenced MXS now can handle scenes with other referenced MXS files inside (nested references).

  • Improved the Referenced MXS display performance - in case there are several Referenced MXS objects with the same MXS file, the plugin uses the same cached MXS scene data for all of these objects.

  • Referenced MXS picking in the viewport in Bounding Box (or Object Bounding Boxes) mode is more precise now.

  • The plugin starts the PathFix command automatically after opening a file if needed.

  • Maxwell Texture button tooltip now shows some information about its options:

  • Maxwell Texture button tooltip now shows the texture type in case the actual channel contains a Rhino texture.

  • The material preview scene list is now in alphabetical order (it was not so in the MacOS version).

 

CHANGES:
  • The default value of the Feature Influence parameter of the Denoiser has been changed to 0.25 so it better preserves the textures features.

  • The Extensions area in the Object Properties panel is now not visible for Referenced MXS objects as Grass or Scatter extensions cannot be assigned to them.

  • Changed the "Toggle Extensions Editor" button icon in the Maxwell Tools toolbar.

 

FIXES:
  • Rhino animation export to Maxwell was not working correctly.

  • The Maxwell Referenced MXS placeholder object (shown when the MXS path does not exist) was not selectable.

  • Maxwell was sending error/warning messages about missing IOR path even if the BSDF was set to custom IOR mode.

  • The plugin didn't pass the custom command line params to Maxwell.

  • (Rhino 7 only) Maxwell Object Properties tab was not visible for Subdiv Surfaces.

  • In the case the Rhino scene was saved with a viewport in Fire mode but the active view was not the FIRE viewport, after reloading the file, the FIRE viewport was using the camera from the active viewport instead of its own camera.

  • Creating a Maxwell Material by importing it from an MXM or the online gallery (from the Maxwell Material toolbar) crashed Rhino in the case Maxwell Fire was running in GPU mode.

  • Changing Maxwell Material preset could crash Rhino.

  • Maxwell Texture button right-click menu (remove / copy / paste) was disabled in the case the actual channel contained a Rhino texture.

  • Maxwell Texture button tooltip was showing wrong information in the case the actual channel contained a Rhino texture.

 

KNOWN ISSUES:
  • In Rhino Render mode, the Maxwell textures don’t show in the material preview.

  • When a Maxwell Material has a Rhino procedural texture too, when switching between textures, the Rhino viewport doesn't show the change of the material (workaround: we have to move the object a bit, set display mode to something else and back to rendered)

  • In the Windows version of Rhino 7, you may find that the main material preview only updates with new material settings but not when you get back to the same setting; this only happens when the material editor is docked and only in the main preview; the floating preview and the double-click preview work fine and also if the material editor is shown in a floating window. We believe this to be a Rhino bug.

 

Maxwell Rhino v5.2.6.0 - 09 Mar 2021

COMPATIBILITY:
  • Built for Maxwell Render 5.2.0.45

  • Added support for Rhino 7

IMPROVED:
  • New Denoiser implementation in Maxwell Render. Only one pass is needed, the denoiser information is now stored in the mxi file as another channel, better memory management for the denoising process, and more consistency in general.

    • New Denoiser options in the Rendering panel > Maxwell for Rhino > General tab > Denoiser section:

      • New Tiling option with maximum tile size option.

      • New fine-tuning options: Color Influence 1 and 2, Feature Influence, Final Pass, Filter Radius and Firefly Remover options. Check this link for more information: denoiser documentation page.

    • New Denoiser channel added in the Rendering panel > Maxwell for Rhino > Output tab > Channels section as now the Denoiser is treated as another channel. This channel activation is synced with the Denoiser enabler in the General tab.

  • Material’s texture and color display in the viewport has been greatly enhanced.

    • You can now select any texture to be displayed in the viewport by single-clicking its texture chip. It will be marked with a blue colored border.

    • The plugin displays the color of the Maxwell Material additive layers inside Rhino viewport more correctly.

    • The plugin now shows the color and textures of the different material assistants inside the Rhino viewport.

    • Added a more detailed tooltip to the texture chip.

  • The Maxwell materials are now exported with the same active texture to be displayed in the viewport as set in Rhino (Maxwell Studio uses this active texture to decide which texture to show inside the Studio viewport).

  • The most important component of the Maxwell Material is automatically selected for display in the Maxwell Material UI after the following actions:

    • Maxwell material assistant: Convert to Advanced

    • Maxwell Referenced material: Embed

    • Command: Maxwell_MaterialReplacer

    • Command: Maxwell_AddMaterial

  • The scenes with lots of nested block instances are now exported much faster. (up to 10-100 times faster...).

  • The Embed option of the Referenced MXM files can now also import the Material assistants as such.

  • Rhino 5 scene import improvement. The plugin now creates dummy materials with the same name as the materials from the V5 scene (the Maxwell material settings are not imported, only the name and the association). This, used in conjunction with the command Maxwell_MaterialReplacer can be used to easily bring all the materials back from older scenes.

  • The Maxwell Render Settings > Extra Sampling > Custom Alpha “A” button opens the Custom Alpha context menu (with an extra "(open editor...)" menu item) that opens the Custom Alpha editor panel.

ADDED:
  • New Substance Designer extension. It can be accessed from the Type dropdown menu from any material or right-clicking on the Create Substance Material from the Materials toolbar.

  • Added support for Maxwell Grass and Maxwell Scatter extensions.

    • New Maxwell Extensions editor panel.

    • New button "Toggle Extensions Editor" added to the Maxwell Tools toolbar.

    • New command "Maxwell_ToggleExtensionEditor"

  • New Maxwell_ShowToolbars command (to show all the Maxwell toolbars).

CHANGED:
  • Single-clicking on a Maxwell material texture button doesn't open the texture editor panel but toggles the display of the texture in the viewport on and off.

  • Double-clicking on a Maxwell material texture button now opens the texture editor panel.

  • (MacOS only) Maxwell toolbars now have the "Maxwell " prefix: Maxwell Rendering, Maxwell Materials, Maxwell Tools to better tell apart the plugin toolbars from the rest.

FIXED:
  • After opening the texture editor panel (clicking on Maxwell Material texture chip) the first mouse click on the Texture dialog didn’t do anything. There’s no need to double-click now to load a texture, for example.

  • The logged scene export time was wrong. The displayed time was also including the time required to accept or dismiss the file overwrite dialogue which was not ok.

  • FIRE display was wrong in the case the output format was not a 8bit/color format.

  • (MacOS only) Rhino didn’t see the Maxwell license in case the customer name contained non-ASCII characters.

  • (Rhino7 only) Maxwell material preview didn’t work.

 

Version 5.1.6.3 - 01 Oct 2020

ADDED:
  • Maxwell Referenced MXS object.

    • In the case no Rhino material was applied to the Referenced MXS object, it is displayed in Rhino Viewport with a greenish Maxwell material and will use its original materials inside Maxwell.

    • In case the user adds Rhino material to the Referenced MXS object, it overwrites the original scene materials (inside Rhino viewport and also inside Maxwell).

    • LIMITATION: Maxwell MXS references instances inside Rhino blocks are not displayed correctly after reloading the scene and are taken by Rhino as normal objects, however, they will render fine.

    • LIMITATION: because of a Rhino API limitation, if you put the MXS reference into a block in order to instance it and then you use the “Edit in Place” command, the objects inside will be displayed as cubes of the size of the bounding boxes of the references in the viewport; they will render fine. As a workaround, you can explode the block and recreate it with the same name. The instances will be updated and displayed correctly.

  • "Maxwell_AddMaterial" command to add/import basic material types.

  • New Maxwell Material toolbar with shortcuts to add the different types of Maxwell materials with options to add many materials at the same time to the Rhino file (for example, you can now import all the mxm materials from a folder in one go).

  • New Maxwell Tools toolbar (currently it only has one button: "Add Referenced MXS", but it will host the extensions buttons and other tools in the near future).

  • New Pack and Go feature available from the rendering toolbar the Maxwell menu and the command line (Maxwell_PackAndGo).

  • New Override material option in the Rendering panel > Maxwell for Rhino > Global tab > Materials. It will replace all the materials of the scene except for the emitters with the material of your choice (great for clay renders).

  • New Default material option in the Rendering panel > Maxwell for Rhino > Global tab > Materials which defines the material used when the object doesn’t have any material applied.

IMPROVED:
  • The name of the exported Rhino object inside the Maxwell scene now follows these rules:

    • In the case the user has given a name to the object, Maxwell name = user name + the Rhino guid of the object.

    • Otherwise Maxwell name = short description of the object (or the name of the Block) + the Rhino guid of the object.

    • Exported light objects follow these rules too from now on (every name contains the guid of the original Rhino object, which adds another chance to identify the objects).

  • The plugin now writes its plugin id into the exported mxs file.

  • Maxwell Material texture button shows the Texture file path (if any) as a tooltip.

  • Automatic translation of Rhino environment: the intensity value of the Rhino environment texture has been fine-tuned; now it is translated to an IBL with the intensity set to 15 instead of 100, which was excessive.

  • Automatic translation of Rhino gradient environment: the midpoint has been changed from 0.1° to 45.0° and Zenith/Horizont colors have been switched so they match what you expect to see from a natural point of view.

  • New context menu when adding a custom alpha channel to an object (less clicking for the users).

  • The Remove Custom Alpha button is disabled (Custom Alphas list in Object settings) in the case none of the custom alpha channels are selected.

  • Custom Alphas Dialog > add object to custom alpha channel button opens now a context menu. It allows the user to add an object via pick selecting, add the already selected objects or by name (only named objects).

  • While pick-adding objects to a Custom Alpha channel, the plugin allows the selection only for Maxwell-renderable objects/lights.

  • Custom Alphas Dialog -> new tooltips for the +/- buttons.

  • Maxwell Object properties are visible only for Maxwell-renderable objects/lights.

FIXED:
  • FIRE view didn't follow the change when the user changed the visibility flag(s) for a lights object (for example hide flags, opacity, etc.).

  • Converting a Maxwell material (assistant type) to Custom could break the Rhino undo mechanism.

  • After a Maxwell material (assistant type) was converted to Custom, the used texture ids were wrong. 

  • When adding texture to a Maxwell material assistant, the plugin was not activating the texture checkbox automatically.

  • The plugin allowed activating Denoise shadow with AutoConfigure mode "Fast", which is not a possible combination as in fast mode there’s no shadow channel.

  • Maxwell referenced materials were exported to the mxs file as embedded.

  • Switching between different material assistants on the same material could cause weird UI behavior. For example, the Substance assistant doesn't show any parameter.

  • (Rhino 7) The plugin doesn't refresh the Maxwell toolbar properly.

  • The command "Maxwell_ToggleFIRE" and "Maxwell_NewFIREView" could not switch to FIRE mode in the case the user had renamed the display mode to something different than "Maxwell FIRE".

  • The plugin didn't load on some systems.

  • The AboutBox build date was wrong.

 

Version 5.1.6.2 - 16 Jul 2020

ADDED:
  • All the Maxwell Material Assistants (Extensions) have been added.

  • It is now possible to set Maxwell Environment sun location not just by Latitude/Longitude but by Angles or Vector too.

  • Maxwell Material context menu option "Duplicate" in the materials list.

  • New option in Maxwell Render Settings > Output > "Append Camera Name" to add the camera name to the output files.

IMPROVED:
  • The Maxwell Material texture right-click context menu now has Copy/Paste options.

  • Maxwell Material > new Layer and new BSDF component are placed on top of the Hierarchy (instead of at the bottom); this is more in line with the material creation logic.

  • "MXS file already exists" message now shows the actual mxs path.

  • Camera auto-focus can be much faster now.

  • It is possible now to drag and drop Maxwell color to other Rhino color components.

  • It is possible to drag and drop a texture from one Maxwell Material component to another. The user has to hold the mouse over the Maxwell Material component list.

FIXED:
  • (Rhino 7) Maxwell object/camera property icon was in low resolution.

  • Undoing Maxwell Material Add Texture didn't work correctly.

  • (OSX only) Editing Maxwell Texture opened from Maxwell Material could crash Rhino.

  • Removed unnecessary warnings (the Material Preview sent warning messages if the texture was created on a material feature but the texture path was not set).

  • The plugin didn't create the mxs file (so it could not export the scene) if the scene contained geometry without texture coordinates.

  • Camera auto-focus didn't work correctly with block instances.

  • Camera PickCameraFocusDistance command didn't work in perspective view if the mouse was close and above the horizon line.

  • Drag and dropping color from the Rhino to the Maxwell color box resulted in the wrong color.

  • Drag and Dropping Texture to an already occupied Maxwell Texture slot was not undoable.

  • Rhino crashed while drag and dropping Maxwell component texture if the mouse was out of the Maxwell Material editor area.

  • Bsdf Bump value control was always greyed out.

 

Version 5.1.6.1 - 27 May 2020

ADDED:
  • Maxwell Material in "Referenced" mode: added an "Embed" button to convert the mxm file into a Maxwell Custom material.

IMPROVED:
  • Maxwell Material in "Referenced" mode: the Edit button is disabled if the path doesn't contain a valid file.

FIXED:
  • After creating named views, the Maxwell exporter sometimes set the wrong view as the active one for Fire and Render.

  • Maxwell export crashed with camera auto-focus ON.

KNOWN ISSUES:
  • On Mac, due to a bug in Rhino code, sending an undo command right after converting a Maxwell Referenced material into a Custom one, may crash Rhino.

 

Version 5.1.6.0 - 13 May 2020

COMPATIBILITY:
  • Built for Maxwell Render 5.1.0.29

FIXES:
  • (WIN Only) The plugin didn't start because of a missing .NET component.

  • Maxwell Texture Override map forgot its changed values.

  • (OSX only) The installer doesn't write the plugin file in case the Rhino MacPlugins folder didn't exist.

  • (OSX only) Maxwell Tool palette command which should open a new FIRE window didn't work correctly. This is due to a Rhino OSX limitation - removed that option from the Maxwell tool palette.

 

Version 5.0.6.3 - 29 Apr 2020

ADDED:
  • Re-written Maxwell Material with an integrated material editor (in the previous version it was called "Maxwell Referenced"). This new material works similarly to Maxwell’s Mxed materials, and it is fully integrated into the Rhino UI. You can now choose from a full-fledged Maxwell material editor or the referenced materials; as in Mxed, you can change from one to the other from the Material’s Global Properties > Type dropdown. The Maxwell Material is fully compatible with the Rhino undo/redo mechanism.

  • New Maxwell Texture. The Maxwell Material by default uses this texture to provide a similar interface as we have under the Mxed texture editor. But the Maxwell Texture is a normal Rhino texture too, so the user can use it for other Rhino materials too.

  • New command "Maxwell_MaterialReplacer" (intended to help Rhino 5 Mac users to load all the materials from older scenes). After the user calls this command and selects the folder with all the mxm files, the plugin replaces the Rhino materials if it finds an mxm file with the same filename as the material name. (For example material "BlackPlastic" is replaced with an existing "BlackPlastic.mxm" file from the selected folder).

  • New UI control in File menu > Properties > Maxwell for Rhino > "Displayed Texture Size". The users can now control the resolution of the Maxwell Material textures displayed inside the Rhino viewport.

  • New UI control in File menu > Properties > Maxwell for Rhino > FIRE Settings > "Baked Texture Size". The users can control the resolution of the baked Rhino textures under the FIRE view (for Rhino procedural textures).

  • New UI control in Rendering tab > Maxwell for Rhino settings > Global tab > "Baked Texture size". The user can control the resolution of the baked Rhino textures under normal Maxwell Render.

  • New Maxwell "Document Properties" page (Maxwell for Rhino > Material Preview) with material preview controls.

  • New UI control in File menu > Properties > Maxwell for Rhino > Decimal Precision.

IMPROVED:
  • 4-5x faster export in the case the scene contains lots of block instances.

  • Maxwell Render parameters undo/redo handling is faster now.

  • Rhino texture export is faster and FIRE more interactive.

  • The plugin now exports the meshes with all of its UV maps (Multi-UV).

  • Maxwell Undo text is more informative now (it shows the name of the changed parameter).

  • In the case Maxwell sends multiple errors or warning messages, the plugin shows all the received messages (not just the last one) after the user clicks on the FIRE view bottom area "* ERROR: CLICK here to see message *".

  • Objects are now exported with their name (if any) plus the id of the object.

  • Block geometries are now exported in block groups.

  • The Document Properties Maxwell pages now have the "Restore Defaults" button.

  • Maxwell for Rhino Document Properties parameters now have default values.

  • (WIN only) The labels of Document Properties Maxwell pages now change to blue if any value has been changed (to show there is a new value to Accept or Cancel).

  • (WIN only) The Maxwell UI controller steppers are now draggable (similar to normal Rhino steppers).

  • (WIN only) When dragging or changing steppers, it doesn't fill the undo stack with in-between data (otherwise, the undo content would be filled with useless data).

  • (WIN only) While changing the color value in the color dialog, it doesn't fill the undo stack with in-between data (otherwise, the undo content would be filled with useless data).

  • The plugin now uses the Eto color button for color properties.

  • Drag and drop between color controls. (Under Windows it is now possible to drag and drop also Rhino colors into Maxwell color buttons).

  • Added warning for the two-point perspective camera (Maxwell doesn't support it).

  • On the command log panel, the plugin writes out the time required to export the scene.

  • Rhino to Maxwell material Texture coordinate export (Known Limitation: rotation works but rotation+scale only in 0/90/180/270 degrees).

  • Maxwell to Rhino material Texture coordinate export (Known Limitation: rotation works but rotation+scale doesn't work - only rotation or scale).

FIXED:
  • (OSX only) The installer couldn’t install the plugin in the case the /Users/<username>/Library/Application Support/McNeel/Rhinoceros/MacPlugins folder didn't exist.

  • Rhino slowed down when a Maxwell material was applied to many objects.

  • Some scenes could freeze Rhino on Maxwell export. It seems it is an issue with Rhino baking; as a workaround, some baking flags are disabled now to avoid this issue.

  • When Custom Alpha was applied to a block, only the first object of the block was exported with the Custom Alpha applied.

  • After changing the object parameter of a block object, FIRE only refreshed the first sub-object of the block.

  • In the case the scene contained several copies of the same instance block, when the user deleted the original block from the scene, all the blocks disappeared from the FIRE view (the copies are handled as instances under Maxwell).

  • Rhino crashed when creating block definitions while FIRE ran.

  • Block inserted from an embedded file (or block with sub-blocks) didn't follow the Maxwell Object settings.

  • The parameters in the Document Properties page were not reverted when clicking the Cancel button. 

  • After undoing the Maxwell Environment Path channel change the value was a text "NULL" instead of an empty string.

  • Camera exposure EV value was wrong if Iso value was not 100.

  • The camera didn't keep exposure correctly in the "Lock Exposure" mode if Iso value was not 100.

  • In some cases, the Maxwell UI panels didn't fit correctly into the parent UI container.

  • Mouse scroll wheeling could cause panning the whole container control instead of spinning the value of the control.

  • After the Rhino view was changed to named view the Maxwell camera showed the saved camera position instead of the active camera position.

  • Rhino’s Gem materials were exported as Rhino’s Custom materials (this was a bug in the Rhino API, but found a workaround).

CHANGED:
  • The camera exposure presets now change Iso/Shutter/F-Stop values too.

  • Maxwell numerical UI controls value change is not immediate now, the user has to accept it with “Enter” or click out of the control. It is also possible to cancel with “Esc”.

 

Version 5.0.6.2 - 06 Feb 2020

COMPATIBILITY:
  • Built for Maxwell Render version 5.0.2.21

IMPROVEMENTS:
  • Added a mini-color-wheel image to Maxwell color controls (to make it easier to see the function of the control).

  • Physical Sky intensity decimal precision is now 4 digits.

  • IBL intensity values and Sun Power, Lat, Lon and North parameters now have a decimal precision of 3 digits.

  • Maxwell UI label width is fixed now, only the remaining part scales with the panel.

  • Maxwell UI Open / Save / Folder side buttons have an icon now (instead of "...")

  • Maxwell UI control values are aligned to the left (to follow similar Rhino controls).

FIXES:
  • Switching Maxwell Material Referenced to another type of material and switching it back crashed Rhino.

  • (WIN only) FIRE crashed in GPU mode.

  • Flickering Maxwell UI panel elements (caused by the right side scrollbar).

  • (OSX only) Maxwell Controls were not readable in Dark Mode.

  • Using a short name for Maxwell output could crash Rhino.

  • After changing Maxwell Environment or Maxwell Material settings in a Rhino Model dialog, Rhino didn't store the new values.

  • After changing Maxwell Render settings inside Document Properties (called from the "Render > Render Properties ..." menu) Rhino doesn't store the new values.

KNOWN ISSUES:
  • (OSX only) Assigning Maxwell materials or environments from a floating window crashes Rhino. A fix for this is expected from McNeel in Rhino 6.23.

  • Make2D tool may crash Rhino if the Maxwell plugin is installed. A fix is also expected from McNeel developers in a future version.

 

Version 5.0.6.1 - 27 Nov 2019

COMPATIBILITY:
  • Built for Maxwell Render version 5.0.1.16

IMPROVEMENTS:
  • In the case the plugin doesn’t find the texture files at the path stored in the MXM file, it will now also try to look for them in the same location as the MXM file (important for the texture display in the Rhino viewport and Fire).

FIXES:
  • Maxwell Render didn’t find the textures of the MXM materials downloaded from the gallery.

  • When loading an MXM file from the Web Gallery, the plugin was not finding the textures (as they pointed to a non-existing folder);

  • (OSX only) In plugin preferences, trying to change Texture Search Paths folders or MXM Gallery Alternative Folder crashed Rhino.

  • (OSX only) Maxwell mxm thumbnail was flipped upside down.

  • Maxwell Referenced Material buttons were not correctly aligned.

  • Exported Rhino 360 Environment was overexposed in Maxwell.

KNOWN ISSUE:
  • Fire in GPU will crash the plugin. It will be fixed in the next version of Maxwell and the plugin.

 

Version 5.0.6.0 - 30 Oct 2019

ADDITIONS:
  • Introduced the version of the plugin for Mac; versions 10.13 (High Sierra), 10.14 (Mojave) and 10.15 (Catalina) are supported.

  • New command Maxwell_ToggleFIRE to activate/deactivate FIRE in an existing viewport.

  • New command Maxwell_NewFIREView to create a new floating window and activate FIRE in it.

  • New command Maxwell_RenderToCloud to send a scene to Maxwell Cloud

  • New Toolbar button to activate/deactivate FIRE in an existing viewport with right-click action to create a new floating window and activate FIRE in it.

  • New button to send a job to Maxwell Cloud with right-click action to send only the selected objects to Maxwell Cloud.

  • New Multilight Group parameter for Rhino lights.

  • New MultiGPU Preferences button added in Rendering panel > Maxwell for Rhino section > Render Settings > Next to the Engine selector when GPU engine is selected.

IMPROVEMENTS:
  • Custom Alpha Editor - Now Add Object button starts Pick selection for objects and adds these objects to the selected Custom Alphas.

CHANGES:
  • Built with Maxwell 5.0.0.14 SDK

  • Replaced toolbar icons with Maxwell 5 versions

 

MAXWELL 4


Version 4.2.6.4 - 07 Oct 2019

ADDITIONS:
  • New Custom Alpha panel and functionality which allows managing the assignment to objects (for the moment, it doesn’t work for materials)

  • New Custom Alpha section in Object’s properties area.

  • New Custom Alpha option in Extra Sampling mask type parameter.

  • New buttons to open Custom Alphas panel from Maxwell’s Object Properties and from Maxwell Render Settings > Output tab > Channels > Custom Alpha

  • New About box in Maxwell menu

CHANGES:
  • "Use Rhino Sun" has been renamed to "Sync with Rhino Sun" (it reflects the behavior better).

  • "Sync with Rhino Sun" is now at the top of the Maxwell Sun settings.

  • In "Sync with Rhino Sun" mode the Maxwell Sun Type and the Rhino sun states are always in synchrony. Changing Maxwell sun type can change the state of the Rhino Sun / or changing the state of the Rhino Sun can change the Maxwell Sun Type.

 

Version 4.2.6.3 - 18 Sep 2019

IMPROVEMENTS:
  • Mesh objects are now exported into layer groups (to Studio).

  • Conversion from Rhino 5:

    • Rhino Gamma is set to default 2.2 (instead of previous 1.0)

    • Rhino 5 environment

    • Rhino 5 render settings (but not the channel settings)

    • Rhino 5 Maxwell Object parameters

    • Rhino 5 Camera parameters (known issue with Named Views)

ADDITIONS:
  • New command Maxwell_PickCameraFocalDistance (in V6 this command sets the focus to the intersected surface or Mesh point and it is interactive in FIRE views)

  • New button for Maxwell_PickCameraFocalDistance on the Maxwell camera panel.

  • Camera Focus mode (Target/Manual/Auto) and Manual Focus Distance parameters.

  • Extra controls (FOV/Azimuth/Angle) for FishEye, Spherical and Cylindrical lenses.

  • Custom Alpha option for Extra Sampling (custom alpha options are still not complete).

  • Automatic light export for Rhino lights: point, spot, linear, rectangular (directional lights are not exported).

  • Maxwell specific parameters in Rhino lights in the Maxwell Object Property tab: IES and Projector light types (only for spotlights) and emission multiplier.

  • Maxwell light parameter "Rotation around dir." for IES and projector types to add an extra control over the orientation of the projected image or IES pattern around the axis of the light (it seems normal Rhino spotlights don't have it).

  • Global render switch for "Displacement"

  • Global render switch for "Dispersion"

  • Animation export mode. In case the actual Rhino renderer is Maxwell and user runs the "Record Animation" command the plugin exports the frames in animation mode. (After all the frames have been exported the user can control how animation runs in the new "Maxwell Animation Controls" dialog). Limitation: in the case of sun study Maxwell always uses the Rhino sun data even if the Maxwell Environment was set for a specific location and date.

  • The plugin opens Overwrite warning dialog in case the output mxs file already exists.

FIXES:
  • Color type Maxwell controls were initially white sometimes - instead of the actual color.

  • Maxwell camera didn't match Rhino Parallel view (in rare cases).

  • lowPriority flag had no effect for the Maxwell Render priority.

  • The plugin read back wrong Maxwell Sun date/time settings in rare cases.

 

Version 4.2.6.2 - 16 Jul 2019

IMPROVEMENTS:
  • Moving meshes under FIRE can be faster now.

  • Dialog with text message helps to identify Maxwell initialization failures.

FIXES:
  • Plugin could not read the license if it contains non-ASCII characters.

  • (Win7 and Win8.1 only) Plugin made Rhino crash at program start.

  • Views with similar names could confuse the Maxwell exporter.

  • Moving object in FIRE mode which had Maxwell Spotlight Emitter material could crash Rhino when using Fire.

Version 4.2.6.1 - 28 Jun 2019

IMPROVEMENTS:
  • The Font for Maxwell controls has been changed to match better the default Rhino UI and also because it has better readability.

  • If the current environment is a Rhino environment, it is also exported to Maxwell. It translates the color but if a texture exists it is translated as IBL.

  • Rhino sun change updates the displayed Maxwell Environment (under the Rhino Render view too).

  • Rhino sun automatically converted even if the actual Environment is not Maxwell Environment.

  • Render Wallpaper environment mode is exported to Maxwell as IBL environment with a planar background (in Maxwell it is always stretched to fit the render frame).

  • In the case of a FIRE error or warning, the viewport status shows that we have Error/Warning message from FIRE. By clicking on it a message dialog appears with the FIRE message.

  • In case of a FIRE error the displayed FIRE screen is black.

  • Better warning or error messages.

  • "Maxwell Referenced" material has its own type icon.

  • The create NEW mxm material button opens now the newly created material automatically in Mxed.

FIXES:
  • In Maxwell Render meshes were in wrong positions.

  • Maxwell export with a named view(s) could crash Rhino.

  • Maxwell Environment Sun date/time (with some localized formats) could crash Rhino.

  • Maxwell placed the objects in the wrong position during dynamic transforms (depends on scene base scale).

  • Rhino materials were not exported (in non-English Rhino versions).

  • Typo "Pin Holde" -> "Pin Hole".

  • Rhino viewports were full black after Maxwell Fire was used and after that, a new scene (or other scenes) was opened.

CHANGES:
  • Rhino sun Enabled status is used if Maxwell Environment uses Rhino sun.

  • The "Maxwell Material" name has changed to "Maxwell Referenced".

  • In the case a Rhino environment is used (not Maxwell) and there is a background image, the plugin converts it to IBL and uses the image for all the IBL channels.

KNOWN ISSUES:
  • The plugin is still crashing Rhino on Windows 7 or 8.1 because of a problem with Microsoft Redistributable files. We'll try to workaround this in the next version.

Version 4.2.6.0 - 18 Jun 2019

What you can and cannot expect in this version

  • You will be able to set all the general settings (previous output tab) in Rhino’s Rendering tab. Here you will be able to set Maxwell as render engine, set engine and render settings, Multilight, Extra Sampling, Denoiser, Output options, Channels (without custom alpha), Globals, Tone Mapping, Simulens and Overlay Text options.

  • In Rhino’s Environment tab you will be able to create as many Maxwell Environments as you want. All the environment options are implemented and Rhino options like Solid color or Gradient are translated to Maxwell if used and you will be able to preview Maxwell Environment in the viewport if it is set to Rendered, Raytraced or Maxwell FIRE modes. Rhino’s sun can also be used to set the time and date as well as location; if so, you will also be able to preview the sun in Rendered and Raytraced modes; if you don’t use Rhino’s sun you will only be able to preview the sun in FIRE.

  • You can currently launch FIRE only in a viewport like any other visualization mode, although you can have it in a floating Rhino’s viewport. The bottom bar at the Fire window is active and you can start/stop, change quality settings and SL from there.

  • At Rhino’s Materials tab you can add Rhino materials (which will be translated to Maxwell at render time) as well as referenced Maxwell materials. Currently, there’s no integrated material editor yet, but you can access MXED from within Rhino to edit the materials. The materials will show their preview in the list and the geometry in the viewport will show the main texture of the material projected onto it if the viewport is set to Rendered, Raytraced (Cycles) or Maxwell FIRE modes. Regarding Rhino materials, all of them are translated as well as Rhino procedural textures.

  • At Rhino’s Properties tab you can check both camera’s and object’s properties depending on if there’s none or any object selected. The camera properties section is complete except for the parameters of the special lenses (which have not yet been added): fisheye, spherical, cylindrical or stereo ones.

  • Additional settings like search paths, mxm gallery download folder or Fire settings can be tuned in Rhino’s Document Properties window

  • What you won’t find yet in the plugin: extensions, like grass, scatter, sea or volumetrics. Custom alphas have not yet been implemented, as well as the material assistants or an integrated material editor. Some secondary features like blocked emitters, material override, etc. are still pending. Also, Fire still feels a bit sluggish, but we will try to find the cause for that.